New Mining Pool

Mining Rigs, mining optimization and pools for Verium
Post Reply
User avatar
Senicar
Posts: 6
Joined: Thu Aug 03, 2017 2:13 am

Fri Aug 04, 2017 4:18 am

TL;DR: Anyone want to help me test my pool?

I found Verium and Vericoin when I was looking for ASIC-resistant CPU-mineable altcoins. This was one of the few that was still in active development and had an active community, so that got me interested.
I downloaded and installed the qt clients and got them working after manually resolving the dependencies which are no longer in the Ubuntu repos by default.

I wasn't able to connect easily to the poolinat0r pools, so I decided to give a shot at setting up my own node and pool and pointed my miner at it.

I'm 90% sure that everything is working but the hashrate from my one miner isn't enough to actually get any blocks in a reasonable timespan.

The mining fee is 0.75%, with manual and automatic cashouts that can trigger at 1 VRM. This should be lower than the other pools.

The url is https://vrm.poolsloth.com and once you set up a worker you can point it at stratum+tcp://stratum.poolsloth.com:3333

Email notifications should be working, tested on my own mailserver and gmail.

Anyone want to help me test this out?

Questions? Comments? Concerns?

Jwnn
Posts: 8
Joined: Thu Aug 03, 2017 1:07 pm

Fri Aug 04, 2017 5:37 am

Sure! Although I'll probably only be contributing 1200 H/m.

User avatar
Senicar
Posts: 6
Joined: Thu Aug 03, 2017 2:13 am

Fri Aug 04, 2017 1:38 pm

Hey, thanks! I saw your registration pop up. Were you able to receive/confirm your email?

Also, were you able to point your miner at the port?

Jwnn
Posts: 8
Joined: Thu Aug 03, 2017 1:07 pm

Fri Aug 04, 2017 2:45 pm

Yes I got the email and yes I was able to point it at the port!

But unfortunately I'm new to this mining stuff and am still working out some kinks in my miner.
As you may have seen from my post on these forums I'm trying to mine with a Ryzen 7 1700.
I haven't yet figured out how to make the software use less than 16 threads and so when I start mining the computer crashes after a bit due to lack of resources.
I've been trying to get the cpuminer software to work for solo mining but haven't been able to figure that out either.

Do you have any insight?

User avatar
Senicar
Posts: 6
Joined: Thu Aug 03, 2017 2:13 am

Fri Aug 04, 2017 3:58 pm

I'm still getting the statistics to display properly on the front end, but on the back end I could see accepted shares for your worker. So whatever you were doing, it was mining.

I'm using the verium miner you were linked to in that other thread on Ubuntu 16.04, not windows.

Can you boot your computer into Ubuntu when you want to mine?

Installing the miner there was pretty simple:

Code: Select all

git clone https://github.com/effectsToCause/veriumMiner
cd veriumMiner
./autogen.sh
./configure CFLAGS="-march=native" --with-crypto --with-curl 
make
./cpuminer -o stratum+tcp://stratum.poolsloth.com:3333 -O Senicar.worker:password -t 32
I'm not super familiar with mining from the wallet on windows, unfortunately.

Jwnn
Posts: 8
Joined: Thu Aug 03, 2017 1:07 pm

Fri Aug 04, 2017 4:59 pm

I was mining through the verium miner linked to me on Ubuntu but I'm not very comfortable operating Linux and it took me alot of trial and error to finally get it going. My issue is getting that miner to use 15 instead of 16 threads so that the computer is still usable. I also can't figure out how to get it to solo mine. I was hoping that miner would better utilize ryzen, did you see what my hashrate was?

User avatar
Senicar
Posts: 6
Joined: Thu Aug 03, 2017 2:13 am

Fri Aug 04, 2017 5:59 pm

I couldn't see a hashrate, no :/

I could see shares being accepted but statistics was reporting 0 H/s for all users (which is obviously not true).

There's something weird with the statistics happening that I'm trying to fix.

It should tell you your hashrate in the CLI output when you ran the miner though.

Here's what mine looks like:

Code: Select all

[2017-08-04 17:52:32] accepted: 34/34 (100.00%), 0.07 kH/s yes!
[2017-08-04 17:52:52] Total: 4373.13 H/m
[2017-08-04 17:53:02] Total: 4400.88 H/m
[2017-08-04 17:53:51] Total: 4384.46 H/m
[2017-08-04 17:54:00] Total: 4334.25 H/m
[2017-08-04 17:54:49] Total: 4378.49 H/m
[2017-08-04 17:55:48] Total: 4340.70 H/m
[2017-08-04 17:56:38] stratum.poolsloth.com:3333 scrypt² block 109540
[2017-08-04 17:56:47] Total: 4382.82 H/m
[2017-08-04 17:57:36] Total: 4389.25 H/m
[2017-08-04 17:58:35] Total: 4379.02 H/m

Jwnn
Posts: 8
Joined: Thu Aug 03, 2017 1:07 pm

Mon Aug 07, 2017 10:46 pm

My miner is now running and contributing!

User avatar
Senicar
Posts: 6
Joined: Thu Aug 03, 2017 2:13 am

Tue Aug 08, 2017 9:07 pm

Thanks!

The pool is now running at 12 workers, 0.38 kH/s, still no blocks found.

Boneless
Posts: 1
Joined: Sun Aug 13, 2017 1:21 am

Sun Aug 13, 2017 2:39 am

Hi Senicar, I just signed up in your pool, the miner is working fine and its submitting shares, but i have a question: in the pool my hashrate appears as 0.02, is that normal?... On poolinator my hashrate seems to be ok... And other thing, despite the fact that the miner is working fine, on the pool i can't see the shares on the share information section, by the time i'm writing this, the worker shows me 165 shares accepted and gowing, but the pool only shows 1. I'm using cpuminer on windows 8,. I'll going to upload an image for better explain. Thanks in advance for your help, for the pool and sorry for my english.

Post Reply
  • Information
  • Who is online

    Users browsing this forum: No registered users and 1 guest